[debian-devel 00317] パッケージのアップデート作業項目

Hideki Yamane henrich @ iijmio-mail.jp
2019年 10月 16日 (水) 14:06:23 JST


 やまねです。
 最近パッケージのメンテでバグ修正以外のことばかりやってます。
 作業リストをdebian-fontsに投げたので、こちらにもFYIということで
 共有します。古くからあるフォントパッケージ特有の項目もありますが、
 多くは普遍的です。

 自分のメンテするパッケージを更新する際の目安にどうぞ。



**Check list**

 * debian/control
   - Bump up Standards-Version: 4.4.1 (latest one)
   - Drop Breaks: and Replaces: with old ttf- package since it was several
     years ago and there are 3 or 4 releases between them
   - Drop Pre-Depends: dpkg and maintainer scripts for defoma as well
   - Set Build-Depends: debhelper-compat (= 12) and drop debhelper
   - Add Rules-Requires-Root: no
   - Use https for Homepage:
 * Drop debian/compat, use debhelper-compat as above
 * Drop extreme compression setting in debian/rules
 * Use https in debian/copyright
 * Use v4 syntax in debian/watch
 * Add debian/gbp.conf if we use non-master branch for debian packaging
 * Add salsa-ci.yml (and disable BLHC and BUILD_PACKAGE_ANY in it) and
   enable it on salsa setting


-- 
Regards,

 Hideki Yamane     henrich @ debian.org/iijmio-mail.jp


debian-devel メーリングリストの案内