[debian-users 00327] Re: Linux 4.9.0-4-amd64

Keiji KOSAKA kgk @ film.rlss.okayama-u.ac.jp
2018年 8月 31日 (金) 00:35:39 JST


小坂@岡山です。

カーネル・オプションに i915.modeset=0 を追加すれば、Linux 4.9.0-8-amd64
でも、画面が正常にうつることが分かりました。
この対処法が正しいかどうかは、分かりませんが。
-- 
KGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGK
  KGK (life name: Keiji KOSAKA), Dept. of Phys., Okayama Univ.        
 kgk @ film.rlss.okayama-u.ac.jp http://film.rlss.okayama-u.ac.jp/~kgk/ 
KGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGKGK

Keiji KOSAKA <kgk @ film.rlss.okayama-u.ac.jp> writes:

> 小坂@岡山です。
>
> 未だに解決してない、この問題ですが、最近少し分かったことがあります。
>
> Keiji KOSAKA <kgk @ film.rlss.okayama-u.ac.jp> writes:
>
>> 小坂@岡山です。
>>
>> LIFEBOOK AH53/U で debian stretch を動かしてます。
>> 順調に動いてたんですが、急に、立ち上がらなくなりました。
>> 本当は立ち上がってるみたいなんですが、画面が真っ暗で何も見えない状態。
>>
>> いろいろ試した結果、どうやら、Linux 4.9.0-4-amd64 では画面真っ暗で、
>> Linux 4.9.0-3-amd64 では正常に立ち上がるもよう。
>>
>> linux-image-4.9.0-4-amd64 を再インスールしても症状が変わらなかったので、
>> Linux 4.9.0-3-amd64 でしのいでます。
>
> Xorg.0.log を調べたところ、4.9.0-3 では、
>
> [    26.953] (II) modeset(0): Output eDP-1 has no monitor section
> [    26.954] (II) modeset(0): Output HDMI-1 has no monitor section
> [    26.957] (II) modeset(0): EDID for output eDP-1
>
> という感じなんですが、4.9.0-4 では、
>
> [    26.281] (II) modeset(0): Output HDMI-1 has no monitor section
> [    26.282] (II) modeset(0): EDID for output HDMI-1
> [    26.282] (II) modeset(0): Output HDMI-1 disconnected
> [    26.282] (WW) modeset(0): No outputs definitely connected, trying again...
> [    26.282] (II) modeset(0): Output HDMI-1 disconnected
> [ 26.282] (WW) modeset(0): Unable to find connected outputs - setting
> 1024x768 initial framebuffer
>
> ってな感じ。(4.9.0-8 でも似たようなもの)
> どうやら、eDP-1 を探そうとしてない様子。
>
> 外部モニターを繋げば見えるかもしれないと思いつつ、まだ試してません。


debian-users メーリングリストの案内