[debian-users 00304] Re: winbind インストールエラー

Tomoo Nomura nomurat @ tmo.co.jp
2018年 6月 1日 (金) 09:16:15 JST


自己RESですが、少しわかってきました。

1) 起動しない理由は
/lib/security/pam_winbind.so が見つからないからでした。
/lib/x86_64-linux-gnu/security/pam_winbind.so 
はあるので、linkなりcopyなりしてやれば、ここは解決です。

2) 次にapt-get 
upgradeでエラーとなるのは、winbindインストール時の再起動scriptのようです。これは、samba-ad-dcが起動している時、既にsamba-ad-dcによりwinbindが起動しているため、エラーとなるようでした。
一旦samba-ad-dcをstopし、apt-get 
upgradeを行えば、winbindは正常にインストールされるようです。

3) 
根本の原因はsamba-ad-dcがwinbindを立ち上げるのに、winbindを別途立ち上げようとするところにあるようなので、
systemctl disable winbind で自動起動を抑制してやり、samba-ad-dc 
のみの起動としてやり解決です。

この問題は、stretch,buster どちらにも現れる症状のようです。
さて、正しい解決策はどうなんでしょうか?

野村

On 05/31/2018 05:54 PM, Tomoo Nomura wrote:
> こんにちは。
> 
> stretchなんですが、昨日upgradeしたsambaがおかしくなり、ログインできない 
> 状態です。
> 調べると、次のモジュールがインストールエラーでした。
> 
> winbind (2:4.5.12+dfsg-2+deb9u2)
> 
> 再起動時に起動できないようなんですが、それ以上のメッセージがありません。
> なにか情報ありませんか?
> 
> 野村


-- 
************** Nomura Technical Management Office **************
  Tomoo Nomura      nomura @ tmo.co.jp       http://www.tmo.co.jp/
     Phone: +81-78-797-0240 Fax: +81-78-754-8240
  Guitar Salon TMO http://www.tmo.co.jp/salon/
****************************************************************


debian-users メーリングリストの案内