[debian-users 00430] Re: Debian8でのアップデートエラー

Tatsuki Sugiura sugi @ nemui.org
2019年 4月 18日 (木) 09:07:15 JST


杉浦です。

On Wed, 17 Apr 2019 17:26:41 +0900,
清水裕暁 wrote:
> メッセージから、/etc/apt/sources.listの以下部分で
> ============================================================
> deb http://ftp.jp.debian.org/debian/ jessie-updates main
> deb-src http://ftp.jp.debian.org/debian/ jessie-updates main
> ============================================================
> http://ftp.jp.debian.org/debian/dists/jessie-updates/main/source/Sources
> がないため、エラーとなっていると考えています。
> 
> /etc/apt/sources.listはデフォルトのまま利用しており
> Debian8のLTSサポートが2020-06-30までであるため、該当リポジトリも問題なく利用できると考えていたのですが、何
> かしらポリシーなどが変更されたのでしょうか。

結論だけ先に書くと、jessie-updates の2行だけ消してください。

LTS の長期サポートに移行した時、レポジトリのレイアウトと言うか提供される物が
多少変わり、 stable-updates はなくなります。現状、jessie インストール時の
apt line が完全にそのままエラー無く使えるという感じではないですね……。

stable-updates はタイムゾーンとかウイルススキャナのデータとかそういったものを
ポイントリリースに先んじて取り込むための apt-line です。しかし、LTS になると
そもそもポイントリリースはこれ以上されなくなり、過去のポイントリリースで既に取り
込まれているこのレポジトリはなくなります。

詳しくはこのへん https://wiki.debian.org/StableUpdates

LTS 自体の使い方は
https://wiki.debian.org/LTS/Using
にあります。

-- 
Tatsuki Sugiura   mailto:sugi @ nemui.org


debian-users メーリングリストの案内