[debian-users 00455] Re: migemo-el から elpa-migemo へ

Youhei SASAKI uwabami @ gfd-dennou.org
2019年 7月 27日 (土) 21:35:10 JST


副島様: elpa-migemo メンテナの佐々木です。

On Sat, 27 Jul 2019 16:07:05 +0900,
Takeshi Soejima <sohet @ mbox.kyoto-inet.or.jp> wrote:
>
> 最近の Buster へのアップデートに伴い、migemo-el のパッケージが
> elpa-migemo に移行しましたが、自分で (require 'migemo) しないと使えな
> くなっています。これまで Debian の elisp パッケージは大概、インストー
> ルしただけで使えたように思いますが、方針が変わったのでしょうか? (バグ
> とは言えない気がしましたので、こちらでお聞きします)

elpa-migemo の移行時に /etc/emacs/site-start.d/50migemo-el を消したから,
ですね。このファイルでは辞書の文字コードや regexp の無効化といった「決め
打ち」をいくつかやった上で, 強制的に migemo を有効化しておりました(ので,
インストールしただけで使えていました)。

ですが migemo を有効にしておくと他の拡張で誤動作するので自動で強制的に有
効化するのは止めて欲しい, という意見も頂いたので, elpa-migemo に移行する
際にこのファイルを消しました。今から思えば
/usr/share/doc/elpa-migemo/README.Debian あたりにちゃんと記載しておくべ
きでした。すみません。

そんな訳で, 御不便かもしれませんが, 御自身の .emacs にて明示的に
migemo-init して下さい。

よろしくお願いします。

--
Youhei SASAKI <uwabami @ gfd-dennou.org>
              <uwabami @ debian.or.jp>
GPG fingerprint:
  4096/RSA: 66A4 EA70 4FE2 4055 8D6A C2E6 9394 F354 891D 7E07


debian-users メーリングリストの案内