[debian-users 00778] Re: 音が出なくなりました

竹内雅文 tianlou0delphyne @ gmail.com
2022年 1月 27日 (木) 20:22:12 JST


PulseAudioのDBusErrorは消えたのですが
相変わらずpcmからの音が拾えないらしく
メインボリュームしか触れない状態です。
また起動し直すたびにパラメータを呼び出して
[LineOut]を選択し直さないと音は鳴りません。

/dev/snd$ ls -la
total 0
drwxr-xr-x   3 root root      340 27 janv. 16:12 .
drwxr-xr-x  18 root root     3560 27 janv. 16:12 ..
drwxr-xr-x   2 root root       80 27 janv. 16:12 by-path
crw-rw----+  1 root audio 116,  4 27 janv. 16:12 controlC0
crw-rw----+  1 root audio 116, 13 27 janv. 16:12 controlC1
crw-rw----+  1 root audio 116,  3 27 janv. 16:12 hwC0D0
crw-rw----+  1 root audio 116, 11 27 janv. 16:12 hwC1D0
crw-rw----+  1 root audio 116, 12 27 janv. 16:12 hwC1D1
crw-rw----+  1 root audio 116,  2 27 janv. 16:13 pcmC0D3p
crw-rw----+  1 root audio 116,  6 27 janv. 16:14 pcmC1D0c
crw-rw----+  1 root audio 116,  5 27 janv. 16:43 pcmC1D0p
crw-rw----+  1 root audio 116,  7 27 janv. 16:12 pcmC1D1p
crw-rw----+  1 root audio 116,  8 27 janv. 16:12 pcmC1D2c
crw-rw----+  1 root audio 116, 10 27 janv. 16:14 pcmC1D4c
crw-rw----+  1 root audio 116,  9 27 janv. 16:14 pcmC1D4p
crw-rw----+  1 root audio 116,  1 27 janv. 16:12 seq
crw-rw----+  1 root audio 116, 33 27 janv. 16:12 timer

$ cat /proc/asound/pcm
00-03: HDMI 0 : HDMI 0 : playback 1
01-00: ALC1220 Analog : ALC1220 Analog : playback 1 : capture 1
01-01: ALC1220 Digital : ALC1220 Digital : playback 1
01-02: ALC1220 Alt Analog : ALC1220 Alt Analog : capture 1
01-04: ALC1220 Analog : ALC1220 Analog : playback 1 : capture 1

ということで

$ aplay -D hw:0,3 Noise.wav
Lecture WAVE 'Noise.wav' : Signed 16 bit Little Endian, Fréquence 48000 Hz,
Mono
aplay: set_params:1349: Nombre de canaux non disponible

というように表示が出ますが、
音が聞こえるわけではありません

.asoundrcというファイルを作って

pcm.!default {
        type plug
        slave {
                pcm "hw:0,3"
        }
}

ctl.!default {
        type hw
        card 0
}

としてみましたが、
これでは駄目なようですね

なお、野宮さんのおっしゃっておられる
vid=
というのは、無効な指定なので無視する、
という表示がsyslogに出ます

2022年1月27日(木) 14:03 野宮 賢 / NOMIYA Masaru <nomiya @ galaxy.dti.ne.jp>:

> 野宮です.
>
> In the Message;
>
>   Subject    : [debian-users 00775] Re: 音が出なくなりました
>   Message-ID : <
> CANFcSADpSudscPKJmms+wrkPPcJcPKaB5NkzK+cYeSDvQ7+k9w @ mail.gmail.com>
>   Date & Time: Wed, 26 Jan 2022 13:37:23 +0900
>
> [MT] == 竹内雅文 <tianlou0delphyne @ gmail.com> has written:
>
> MT>  [1  <multipart/alternative (7bit)>]
> MT>  [1.1  <text/plain; UTF-8 (base64)>]
> MT>  理由が分らないまま、本日、突然、音が出るようになっています。
> MT>  syslogのPulseAudioのDBus Error表示が消え、その代り、
> MT>  systemd[764]: pulseaudio.socket: Succeeded.
> MT>  という表示が出ていますので、
> MT>  PulseAudioの立ち上げ失敗が解消したので音が出ている
> MT>  ということなのだと思いますが
> MT>  なぜ失敗しなくなったのかが
> MT>  不明です。
>
> In the Message;
>
>   Subject    : [debian-users 00769] Re: 音が出なくなりました
>   Message-ID : <CANFcSAAzx0ZNpunamP3v=
> czB8hMeZfe7zG2jYYEw9j_2+LLxQg @ mail.gmail.com>
>   Date & Time: Sun, 23 Jan 2022 17:26:20 +0900
>
> [MT] == 竹内雅文 <tianlou0delphyne @ gmail.com> has written:
>
> [...]
> MT>  早速、この「趣味の記録部屋」というサイトの教示に従って
>
> MT>  options snd-hda-intel index=1,0 vid=1022,1002
>
> MT>  という内容のalsa.conf ファイルを作って、modprobe.dに
> MT>  置いて再起動してみました
>
>    options snd-hda-intel index=0,1 vid=1002,1012
>
> では?
>
> ---
> ┏━━┓彡   野宮  賢             mail-to: nomiya @ galaxy.dti.ne.jp
> ┃\/彡
> ┗━━┛      「狩猟採集民にしろ牧畜民にしろ「仕事を始める自由、辞める自由みたい
>               なことも含め、自分の意思で生きることに価値が置かれてきた。」」
>                                        --- 松村圭一郎『働くのは何のため?』 --
> _______________________________________________
> debian-users mailing list
> debian-users @ debian.or.jp
> https://lists.debian.or.jp/mailman/listinfo/debian-users
>
-------------- next part --------------
HTMLの添付ファイルを保管しました...
URL: <https://lists.debian.or.jp/pipermail/debian-users/attachments/20220127/7eead054/attachment.html>


debian-users メーリングリストの案内