<div dir="ltr"><div>皆様<br><br>オオツキです。<br><br></div><div>Jessie で backport を入れたりしていたら、モバイルルータが usb0 と認識されず、ストレージデバイスとしてしか認識されなくなって<wbr>しまいました。<br></div><div>backports で入ったものをすべて戻してみましたが、改善しません。<br><br>そこで usb の プロダクト ID を直接いじってみようとしているのですが、エラーとなってしまい<wbr>ます。<br></div><div>※ 一番下の [References] を参考に試してみました。<br><br>何か的はずれなことをやってしまっているのでしょうか?<br>改善方法をご存知の方いらっしゃいますか?<br><br>[ルーター]<br></div>$ lsusb -d 12d1:<br>Bus 003 Device 004: ID 12d1:1f01 Huawei Technologies Co., Ltd. E353/E3131 (Mass storage mode)<br><div><br>[試したコマンド]<br># usb_modeswitch -p 0x1f01 -v 0x12d1 -P 0x14db -V 0x12d1<br># usb_modeswitch -p 0x1f01 -v 0x12d1 -J<br><br>[ログ]<br>dmesg  | grep usb_mode<br>[ 
 972.277901] usb_modeswitch[2589]: segfault at 5 ip 0000000000401c4f sp 
00007ffc1b03eb20 error 4 in usb_modeswitch[400000+c000]<br>[  
978.340456] usb_modeswitch[2596]: segfault at 5 ip 0000000000401c4f sp 
00007ffdc8599980 error 4 in usb_modeswitch[400000+c000]<br><br>$ apt-cache show usb-modeswitch <br>Package: usb-modeswitch<br>Version: 2.2.0+repack0-2<br><br>$ apt-cache show usb-modeswitch <br>Package: usb-modeswitch-data<br>Version: 20150115-1<br><br>[References]<br><a target="_blank" href="https://lists.debian.org/debian-laptop/2015/02/msg00018.html">https://lists.debian.org/debia<wbr>n-laptop/2015/02/msg00018.html</a><br><a target="_blank" href="https://ubuntuforums.org/showthread.php?t=1874253">https://ubuntuforums.org/showt<wbr>hread.php?t=1874253</a><br><a target="_blank" href="http://blog.kawauso.com/?p=748">http://blog.kawauso.com/?p=748</a><br><br>------------------------<br>Key fingerprint = 310C 6FCE 254A E0DF 395D  23A3 D2F2 5C56 84D1 A6F2<br></div><div><br>Yosuke OTSUKI<br></div><div><br><br><br></div></div>