[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debian-users:18300] Re: fetchmail SMTP transaction error



川染さん、こんにちは。水原です。

私は sendmail 8.9.3-3 と fetchmail 4.6.4-1.1 で問題なく使用できています。

At Wed, 13 Oct 1999 21:48:14 +0900,
Ichiro Kawazome <ichiro_k@xxxxxxxxxxxxxxxx> wrote:
> 
>   はじめまして。川染と申します。
> 
>   実は今日、fetchmail を dpkg で4.6.4-1.1 にアップグレードしたのですが、
> メールの受信(と言うより localhost への送信)に失敗するようになりました。
> 今まではなんともなかったのですが...。
> 
>   過去の fetchmail がらみの投稿もチェックしたのですが判りませんでした。
> どなたか、よろしくお願いします。
> 
> fetchmail -k -v での出力は次の通りです(一部伏せ字)。

(中略)

> fetchmail: SMTP> EHLO localhost
> fetchmail: SMTP< 550 You are not permitted to send mail

ここが問題ですね。

smail のソースを見てみたのですが、これは hosts_access(3) がゼロを返して
いることが原因のようです。/etc/hosts.deny や /etc/hosts.allow をいじって
みてはどうでしょう。あと、/var/log/mail.log や mail.err を見てみると何か
情報が得られるかもしれませんね。

あまりやくにたたないアドバイスですみません。

>   ちなみに fetchmail と smail のバージョンは以下の通りです。
> 
> Desired=Unknown/Install/Remove/Purge
> | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
> |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
> ||/ Name            Version        Description
> +++-===============-==============-============================================
> ii  fetchmail       4.6.4-1.1      POP2/3, APOP, IMAP mail gatherer/forwarder
> 
> Desired=Unknown/Install/Remove/Purge
> | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
> |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
> ||/ Name            Version        Description
> +++-===============-==============-============================================
> ii  smail           3.2.0.101-4.5  Electronic mail transport system.

slink (debian 2.1) では、3.2.0.102-1 が最新のようです。
------------
水原@表千家 <mizuhara@xxxxxxx>