[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[debian-users:48725] Re: Etch のカーネルの AHCI について



渡辺です。

とりあえず、分かったところまで報告すると、

= = = ここから = = =
$ apt-get source linux-image-2.6.18-4-amd64
(出力省略)
$ cd linux-2.6-2.6.18.dfsg.1/debian/patches/
$ grep -rli ahci *
features/all/drivers/scsi-ahci-cleanup-3.patch
features/all/drivers/scsi-ahci-suspend-3.patch
features/all/drivers/scsi-ahci-cleanup-4.patch
features/all/drivers/scsi-ahci-suspend-1.patch
features/all/drivers/scsi-ahci-suspend-2.patch
features/all/drivers/scsi-ahci-cleanup-1.patch
features/all/drivers/scsi-ahci-cleanup-2.patch
series/3
= = = ここまで = = =
これらは、bugfix ディレクトリとかでなく、
features のような名前のディレクトリに置かれている
ことから、「セキュリティ関連」というよりは
「アップストリームで受け付ける予定のあるような種類」
であると考えられます。(違っていたらツッコミください)

それぞれのオブジェクト名が、(※私は、Git は使ったことがありません)

d8fcd116d203dfe2f6c272d0cd67724b172f1bc2
c1332875cbe0c148c7f200d4f9b36b64e34d9872
9f5920567bfabbd1be26112a31c44652b6587394
0be0aa98985dfec42502c0d0af2a1baff9bdb19f
d91542c11f3981768367815cf087ad36e792ea4a
5457f2194ad198a0aba4190ec99a6a81846fdca5
254950cd56fee220c9d548f3e57211b95976ba64

なので、これらをもとに、kernel.org の 
ChangeLog-2.6.19 ファイルで該当するものを
検索すると、すべて見付かりました。

= = = ここから = = =
commit c1332875cbe0c148c7f200d4f9b36b64e34d9872
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Jul 26 15:59:26 2006 +0900

    [PATCH] ahci: implement Power Management support

    Implement power management support.

    Original implementation is from Zhao, Forrest <forrest.zhao@xxxxxxxxx>

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Zhao, Forrest <forrest.zhao@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit 9f5920567bfabbd1be26112a31c44652b6587394
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Jul 26 15:59:26 2006 +0900

    [PATCH] ahci: simplify ahci_start_engine()

    Simplify ahci_start_engine() by killing prerequisite condition checks.
    Rationales are..

    * No user checks error return from ahci_start_engine()

    * Code flow guarantees the prerequisite conditions unless the
      controller is malfunctioning.  In such cases, the driver had chances
      to learn about the problem _before_ calling this function.

    * Closely related to the above two, driver calls into this function
      even when prerequisites fail hoping for the best.

    Basically, ahci_start_engine() should only do the operation itself.
    It isn't the right place to check for prerequisites.

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Zhao, Forrest <forrest.zhao@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit 0be0aa98985dfec42502c0d0af2a1baff9bdb19f
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Jul 26 15:59:26 2006 +0900

    [PATCH] libata: improve driver initialization and deinitialization

    Implement ahci_[de]init_port() and use it during initialization and
    de-initialization.  ahci_[de]init_port() are supersets of what used to
    be done during driver [de-]initialization.  This patch makes the
    following behavior changes.

    * Per-port IRQ mask is cleared on driver load as done in other
      drivers.  The mask will be configured properly during probe.

    * During init_one(), HOST_IRQ_STAT is cleared after masking port IRQs
      such that there is no race window.

    * CMD_SPIN_UP is cleared during init_one() instead of being set.  It
      is set in port_start().  This is more consistent with overall
      structure of initialization.  Note that CMD_SPIN_UP simply controls
      PHY activation.

    * Slumber and staggered spin-up are handled properly.

    * All init/deinit operations are done in step-by-step manner as
      described in the spec instead of issued as single merged command.

    Original implementation is from Zhao, Forrest <forrest.zhao@xxxxxxxxx>

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Zhao, Forrest <forrest.zhao@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit d91542c11f3981768367815cf087ad36e792ea4a
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Jul 26 15:59:26 2006 +0900

    [PATCH] ahci: separate out ahci_reset_controller() and ahci_init_controller()

    Separate out ahci_reset_controller() and ahci_init_controller() from
    ata_host_init().  These will be used by PM callbacks.  This patch
    doesn't introduce any behavior change.

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Zhao, Forrest <forrest.zhao@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit d8fcd116d203dfe2f6c272d0cd67724b172f1bc2
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Jul 26 15:59:25 2006 +0900

    [PATCH] ahci: cosmetic changes to ahci_start/stop_engine()

    * fascist-format comments according to comment style used in libata
      core layer.

    * if() -> if ()

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Zhao, Forrest <forrest.zhao@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit 254950cd56fee220c9d548f3e57211b95976ba64
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Jul 26 15:59:25 2006 +0900

    [PATCH] ahci: relocate several internal functions

    * move ahci_port_start/stop() below EH functions.  This makes ahci
      more consistent with other drivers and makes prototypes for
      ahci_start/stop_engine() unnecessary.

    * swap positions between ahci_start_engine() and ahci_stop_engine()
      for readability.

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Zhao, Forrest <forrest.zhao@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =


= = = ここから = = =
commit 5457f2194ad198a0aba4190ec99a6a81846fdca5
Author: zhao, forrest <forrest.zhao@xxxxxxxxx>
Date:   Thu Jul 13 13:38:32 2006 +0800

    [PATCH] The redefinition of ahci_start_engine() and ahci_stop_engine()

    - Make ahci_start_engine() and ahci_stop_engine() more consistent with
      AHCI spec 1.1
    - Change their input parameter from ap to port_mmio
    - Update the existing users of ahci_start_engine() and ahci_stop_engine()

    Signed-off-by: Forrest Zhao <forrest.zhao@xxxxxxxxx>
    Signed-off-by: Hannes Reinecke <hare@xxxxxxx>
    Signed-off-by: Jens Axboe <axboe@xxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

linux-2.6-2.6.18.dfsg.1/debian/changelog
ファイル内の、
linux-2.6 (2.6.18-3) unstable; urgency=low
に、
  * Add AHCI suspend support.
とありますが、これが上記すべてのパッチを表している
ものと推測されます。

kernel.org の ChangeLog-2.6.19 ファイル内で、
ahci で検索すると、もれているものは、次のもの
のようでした。

= = = ここから = = =
commit f33d625f40e3b803c4cdea3219abb96cabf5ea03
Author: Jason Gaston <jason.d.gaston@xxxxxxxxx>
Date:   Tue Nov 21 16:55:58 2006 -0800

    [PATCH] ahci: AHCI mode SATA patch for Intel ICH9

    This patch adds the Intel ICH9 AHCI controller DID's for SATA support.

    Signed-off-by:  Jason Gaston <jason.d.gaston@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit 895663cd92574367054e0eb604a7428852f359b8
Author: Peer Chen <pchen@xxxxxxxxxx>
Date:   Thu Nov 2 17:59:46 2006 -0500

    [libata] Add support for AHCI controllers of MCP67.

    Signed-off-by: Peer Chen <pchen@xxxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>

= = = ここまで = = =

= = = ここから = = =
commit 1244a19cde42c268aa159d264fc2df072a3ff82f
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Nov 1 17:19:18 2006 +0900

    [PATCH] ahci: fix status register check in ahci_softreset

    ahci_softreset() used to use ahci_tf_read() which reads D2H_REG area
    to check for the Status register.  However, this area is zeroed on
    initialization and not set by initial signature FIS.  Replace it with
    ahci_check_status().

    This bug prevented CLO code from being activated whenever BSY and/or
    DRQ is set prior to softreset.  This fix makes
    AHCI_FLAG_RESET_NEEDS_CLO flag redundant.

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit 12a87d36b3c5cb76a182c35f40d959a615d1c862
Author: Alan Cox <alan@xxxxxxxxxxxxxxxxxxx>
Date:   Mon Oct 16 16:21:40 2006 +0100

    [PATCH] ahci: readability tweak

    Signed-off-by: Alan Cox <alan@xxxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
commit f4b5cc874158a139c091b3decd468929e10645e6
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Mon Aug 7 11:39:04 2006 +0900

    [PATCH] ahci: remove IRQ mask clearing from init_controller()

    Initial IRQ mask clearing is done by libata-core by freezing all ports
    prior to requesting IRQ.  Remove redundant IRQ clearing from
    init_controller().

    Signed-off-by: Tejun Heo <htejun@xxxxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =

= = = ここから = = =
ommit 95916edd02e3a7752315422f386c55723d4a3637
Author: Jeff Garzik <jeff@xxxxxxxxxx>
Date:   Sat Jul 29 04:10:14 2006 -0400

    [libata] ahci: add SiS PCI IDs

    Signed-off-by: David Wang <touch@xxxxxxx>
    Signed-off-by: Jeff Garzik <jeff@xxxxxxxxxx>
= = = ここまで = = =


もれているもので気になるのは、Tejun Heo san の

commit 1244a19cde42c268aa159d264fc2df072a3ff82f
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Wed Nov 1 17:19:18 2006 +0900

commit f4b5cc874158a139c091b3decd468929e10645e6
Author: Tejun Heo <htejun@xxxxxxxxx>
Date:   Mon Aug 7 11:39:04 2006 +0900

くらいでしょうか。というか、ICH8 では無問題と
いう気がしてなりません...。

(追伸) 前記の HDD のトラブルは、HDD の故障と判明しました。