[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
[debian-users:28554] Re: unable to root fs!
佐野@浜松 (舞鶴出張中。ホテルの電話を使うとモデムが 3 分で切れる
謎のウルトラマンカラータイマー症を経験中) です。
In <002001c0e6c6$b2010be0$6600a8c0@xxxxxxxxxxxxxxxxxxxx>,
on "Mon, 28 May 2001 00:57:28 +0900',
with "unable to root fs!",
"kenuke higuchi" <shiena@xxxxxxxxxxxxx> さん wrote:
> testingを使っていたら、突然、xーwinndowが落ちて、
> 何か重大なファイルがない、というエラーが発生しました。
「後悔先に立たず」ではありますが、あとあとのためにこのメッセージを
ちゃんと記録しておくと良かったですね。
> とりあえず、exitして再ログインしようとしますと、
> 同じエラーでログインさえできなくなりました。
> #すみません。慌てていたためエラーを記録しませんでした。
まあ、慌てるのは仕方無いことですが、次からなるべく記録しましょう。
> しょうがないので電源を切って再起動すると、
シャットダウンせずに電源を切ったのですね ?
/etc/inittab の
# What to do when CTRL-ALT-DEL is pressed.
ca:12345:ctrlaltdel:/sbin/shutdown -t1 -a -r now
を無効にしていなければ、標準で Ctrl+Alt+Del で再起動する設定に
なっていると思うので、今度からはこれを使うといいです。もし既に
試してみたがダメだったということなら、今後のために Kernel の
Magic SYSRQ key を有効にしておくといいでしょう。
> NET4: Unix Domain sockets 1.0/smp
> fatfs:bogus cluster size
> kernel panic:vfs: Unable to mount root fs on 03:46
もともとは /dev/hdb6 に root があったのですか ?
> となって、rootがmountできずに途中でパニクリます。
> ハードデイスクはちゃんと認識されていました。
ハードディスクを認識するところでパーティション情報もリスト
されていると思いますが、それはどのように表示されていますか ?
> そこで、違うパソコンにハードディスクを繋ぎかえて調べてみました。
>
> fdiskで問題のディスクを調べると、
>
> Command (m for help): p
>
> Disk /dev/hdf: 255 heads, 63 sectors, 1662 cylinders
この C/H/S はもともとの PC での設定と同じ ?
> Units = cylinders of 16065 * 512 bytes
>
> Device Boot Start End Blocks Id System
> /dev/hdf1 * 1 2 16033+ 83 Linux
> /dev/hdf2 3 1662 13333950 5 Extended
> /dev/hdf5 3 18 128488+ 82 Linux swap
> /dev/hdf6 19 261 1951866 83 Linux
> /dev/hdf7 262 626 2931831 83 Linux
> /dev/hdf8 627 869 1951866 83 Linux
> /dev/hdf9 870 1234 2931831 83 Linux
> /dev/hdf10 1235 1662 3437878+ 83 Linux
>
> となり、ちゃんとext2形式で認識されているようなんですが、
これはパーティション情報ですね。ここで「ext2 で認識」というのは
単にパーティション ID がそうなっている、というだけの意味です。
> hdf1、7、10以外は、次のようになぜかマウントできません。
>
> elisis:/# mount -t ext2 /dev/hdf8 /mnt
> mount: wrong fs type, bad option, bad superblock on /dev/hdf8,
> or too many mounted file systems
filesystem が壊れていますね。superblock がおかしいみたい。
e2fsck -n -b 8192 /dev/hdf8 だったかな ? -n で実際には何もしない、
-b 8192 で代替スーパーブロックを使う、というオプションのような気が。
詳細は man e2fsck を。(-n はこれ以上ディスクを壊してしまわないために)
> dmesgは
> VFS: Can't find an ext2 filesystem on dev ide2(33,72).
> とでます。#なんでide2??
ide0 (hda, hdb)
ide1 (hdc, hdd)
ide2 (hde, hdf)
...
となっているのだと思います。
> 一方、hdf1のboot領域と、(automountしていなかった)未使用領域
> のhdf10は、ちゃんとmountされ、中身も大丈夫なのですが、
> hdf7はext2で認識され、中身はrootパーティションでした。
>
> ああrootあるじゃん、と思ったのもつかの間、hdf7には/etcがありません!
> それに、rootパーティションってもともとhdf6だったような!?
謎ですね。dmesg でのパーティション情報のリストを確認したいところ。
> もとのパーティション構成はよく覚えていませんが、
> hdf6>root
> hdf7>usr
> hdf8>var
> hdf9>home
> だった気がします。
>
> もう最悪、homeディレクトリのデータだけでも
> 取り出せればいいんですけど、、、、
> #一週間かけて調べて書いた発表の資料が、、、、
とりあえずは dd でまるごとバックアップして操作を加えても元に
復帰できるようにする、ですかね ? そのあと e2fsck をうまく
使えばある程度救えるかもしれません。
--
# (わたしのおうちは浜松市、「夜のお菓子」で有名さ。)
<kgh12351@xxxxxxxxxxx> : Taketoshi Sano (佐野 武俊)